Error while running a test in Ruby

zen_test1 at 14h44
29
May
2010
Error while running a test in Ruby

Hi,

I'm getting the following error when i run a test in ruby editor. I'm using the Windows XP OS. Can anyone help.

Error :

1) Error:
test_ERAIL(ERAIL):
Errno::EMFILE: Too many open files - socket(2)
c:/ruby/lib/ruby/1.8/net/http.rb:564:in `initialize'
c:/ruby/lib/ruby/1.8/net/http.rb:564:in `open'
c:/ruby/lib/ruby/1.8/net/http.rb:564:in `connect'
c:/ruby/lib/ruby/1.8/timeout.rb:56:in `timeout'
c:/ruby/lib/ruby/1.8/timeout.rb:76:in `timeout'
c:/ruby/lib/ruby/1.8/net/http.rb:564:in [......]
About
This topic belongs to the forum
  • Numbers of topics : 2331
  • Numbers of messages : 6045
  • Numbers of users : 5011
  • Numbers of points : 257
Similar topics
This is a very simple test that open firefox to access an URL. But I keep getting this XHR Error with request code = -1. (The website is ok when manually accessing it). 11:39:31.886 INFO - Command request: open[/, ] on session
Hi, I opened my Ide, file- > new test suite. Then i try to add test cases . getting error. using Mozilla Firefox Browser version 6.0 Error in adding test case to test suite in IDE 1.10.0. Error like,, error loading test case: [Exception..
Hi, Please suggest me why this error msg is coming and how to avoid that error message
I am running my selenium server in background with the help of nssm service. I am running the server at a particular port (11111). I wrote some unit test in VS 2010 and when I am trying to invoke the selenium service with Code:selenium = new
When I tried to run a code(that is perfectly working in IE) in Firefox 3.5, using the code below, selenium = new DefaultSelenium("localhost",4444,"*firefox","http://www.google.com"); firefox displays 'Server not found' error. But when we try to
Forums from same category